%%ItemTitle%%

Pomoc programu Administrator baz danych Asseco WAPRO
Informacje ogólne
Zobacz także Wyślij wiadomość Pytania i odpowiedzi

Glossary Item Box

Informacje ogólne

Moduł administracyjny służy do zarządzania:

  • serwerem Microsoft SQL Server na którym działają programy Asseco WAPRO
  • bazami danych
  • licencjami na użytkowanie programów Asseco WAPRO
  • hasłami kont użytkowników programów
  • połączeniami nawiązanymi z serwerem baz danych

Zobacz także

Uruchomienie administratora
Rozpoczęcie pracy
System zabezpieczeń
Funkcje modułu administracyjnego
Zakładka Licencje

©2013. Wszelkie prawa zastrzeżone.


Uruchomienie administratora
Pomoc programu Administrator baz danych Asseco WAPRO > Uruchomienie administratora

Glossary Item Box

Uruchomienie administratora

  • Moduł administracyjny można uruchomić dwoma sposobami :
  • bezpośrednio z programu wciskając na oknie logowania przycisk Administracja Licencją i Bazami Danych
  • poprzez menu Start systemu windows | programy | WA-PRO | nazwa programu | Administrator <nazwa_programu> np. WF-FaKir.

Administrator baz danych jest jednakowy dla wszystkich programów, jednak do zarządzania każdym programem należy go uruchomić z odpowiedniego menu, ponieważ wtedy administrator zarządza licencjami i strukturami konkretnego programu.

Zobacz także

Uruchomienie administratora

©2013. Wszelkie prawa zastrzeżone.


Rozpoczęcie pracy
Pomoc programu Administrator baz danych Asseco WAPRO > Rozpoczęcie pracy

Glossary Item Box

Rozpoczęcie pracy z administratorem

W celu rozpoczęcia pracy z modułem administracyjnym należy zalogować się do serwera Microsoft SQL Server. Bezpośrednio po uruchomieniu modułu ukazuje się okno służące do logowania :

Powiększ Powiększ
Pomniejsz Pomniejsz

W polu Nazwa serwera należy umieścić nazwę serwera do którego chcemy się podłączyć. Jeśli sieć komputerowa jest siecią NT to po wciśnięciu przycisku znajdującego się po prawej stronie pola uzyskamy listę serwerów SQL dostępnych w sieci.

Nazwa serwera jest zwykle taka sama jak nazwa komputera na którym się on znajduje.

Jeśli z jakichś powodów podłączenie do serwera za pomocą nazwy nie udaje się, a serwer pracuje, to można się do niego podłączyć na kilka sposobów :

  • za pomocą numeru IP komputera na którym znajduje się serwer.
  • Jeśli serwer znajduje się na komputerze lokalnym (tzn. na tym samym na którym obecnie pracujemy), to można się do niego podłączyć wpisując zamiast nazwy serwera :
  • localhost
  • (local)
  • . [sam znak kropki - jest to odpowiednik serwera lokalnego]
  • 127.0.0.1

Jeśli serwer SQL został zainstalowany w trybie instancji nazwanej jego nazwa ma postać NazwaSerwera\nazwainstancji np. Serwer\SQLExpress - gdzie Serwer to nazwa systemu a SQLExpress to nazwa instancji. Analogicznie pod nazwę serwera można zastosować adres IP, słowo localhost lub kropkę.

W polu Login należy wpisać nazwę administratora serwera (nie należy mylić z nazwą użytkownika programu), a w polu Hasło - hasło dla tego użytkownika. Jeśli serwer został zainstalowany za pomocą oprogramowania Asseco WAPRO, to administrator nosi nazwę SA, a hasło to Wapro3000 . Jest to sytuacja zła z punktu widzenia bezpieczeństwa danych znajdujących się na tym serwerze, dlatego zalecamy niezwłoczną zmianę hasła administratora. Można tego dokonać za pomocą tego modułu administracyjnego. Funkcji zmieniająca hasło administratora zostanie opisana w dalszej części tego dokumentu.

Zobacz także

Uruchomienie administratora
System zabezpieczeń
Operacje wiersza poleceń


System zabezpieczeń
Pomoc programu Administrator baz danych Asseco WAPRO > System zabezpieczeń

Glossary Item Box

System zabezpieczeń

System licencji zabezpiecza programy Asseco WAPRO przed ich nieuprawnionym użytkowaniem. Licencja jest udzielana na konkretny serwer (Microsoft SQL Server) i konkretny komputer na którym został zainstalowany serwer. Jeżeli na danym serwerze pracuje więcej niż jedna firma, to możliwe jest utworzenie więcej niż jednej licencji i przyporządkowanie dla każdej z nich oddzielnych baz danych. Dzięki systemowi licencji istnieje jeden program instalacyjny danej wersji programu do wszystkich wariantów.

Przeinstalowanie systemu Windows, na którym pracuje SQL Server lub samego serwera SQL wiąże się z ponowną aktywacją produktów Asseco WAPRO.

Licencja określa:

  • konfigurację produktu :
    • Numer wersji – (pierwsze dwa numery wersji pokazują zakres wersji programu, który może być użytkowany w ramach tej licencji bez konieczności zakupienia aktualizacji; wystarczy zdobyć nową wersję programu i ją zainstalować)
    • Wariant – określa wariant programu w którym chcemy pracować (przed aktywacją licencji można wypróbować różne warianty w celu stwierdzenia, który odpowiada najlepiej potrzebom klienta; aktywacja licencji spowoduje, że licencja przyjmie wariant jaki został zakupiony)
    • Ilość stanowisk (dla programów WF-FaKir, WF-Mag i WF-KaPeR), Ilość środków trwałych (dla WF-bEST) lub ilość pracowników (dla WF-Gang)
    • Numer Licencji
  • dane firmy, która zakupiła licencję
  • dane korespondencyjne – określające sposób komunikowania się klienta z Asseco WAPRO.

Użytkownik razem z pakietem instalacyjnym otrzymuje certyfikat autentyczności, na którym zawarty jest numer seryjny i kod tajny. Należy wprowadzić te dane do parametrów licencji.

Jeśli użytkownik wprowadzi prawidłowe dane licencji oraz będzie posiadał opłaconą transakcję dotyczącą danego produktu, nastąpi próba automatycznej aktywacji produktu po wykryciu dostępu do internetu.

Licencja może występować w następujących stanach (aktywnościach):

  • Wstępna – aktywność świeżo po utworzeniu licencji – umożliwia ona pełne użytkowanie programu przez 30 dni. Przez 30 dni klient powinien dokonać aktywacji tej licencji w celu uzyskania aktywności Pełnej. W przeciwnym razie licencja przejdzie w stan aktywności ograniczonej i nie będzie możliwe korzystanie z pełnych możliwości programu.
  • Pełna – aktywność standardowej pracy po dokonaniu aktywacji programu – umożliwia ona korzystanie z pełnej funkcjonalności danego wariantu programu.
  • Ograniczona – do tej aktywności licencja przechodzi gdy nie zostanie ona aktywowana w ciągu 30 dni lub system wykryje inne nieprawidłowości (przeniesienie serwera na inny komputer, uszkodzenie informacji o licencji).

Proces tworzenia i aktywacji licencji został opisany w punkcie nr 8 pt. „Licencje”.

Bazy danych pamiętają informację o licencji na której były użytkowane. Jeśli dana baza zostanie przeniesiona na serwer, na którym nie ma licencji na użytkowanie tego programu, bądź też licencja taka istnieje ale nie jest w aktywności pełnej, to Baza przechodzi w tryb aktywności weekendowej – może być użytkowana na tym serwerze przez 10 dni. Po tym czasie musi być ona przeniesiona z powrotem na serwer macierzysty, w przeciwnym wypadku jej użytkowanie stanie się niemożliwe.

Jeśli baza zostanie przeniesiona na nowy serwer posiadający licencję w aktywności pełnej i w wersji równej lub nowszej, to użytkowana będzie ona na zasadach określanych przez licencję znajdującą się na nowym serwerze.

Jeśli licencja dotyczy programów z limitowaną ilością stanowisk, to system monitoruje ilość aktywnych połączeń do serwera. Jeśli ilość ta w danym momencie zostanie przekroczona, to system nie dopuści do zalogowania się kolejnego użytkownika.

Jeśli nowsza wersja programu będzie miała zmieniony pierwszą lub drugą cyfrze w numerze licencji, to jej użytkowanie będzie się wiązało z zakupieniem aktualizacji. Do czasu jej zakupienia, będzie możliwe użytkowanie programu w nowej wersji, gdyż zmiana parametrów licencji (zmiana numeru wersji) spowoduje przejście licencji w aktywność wstępną).

Aktualizacja bazy danych możliwa jest tylko na serwerze posiadającym pełną aktywność bądź na serwerze macierzystym.

Zobacz także

Rozpoczęcie pracy
Funkcje modułu administracyjnego


Funkcje modułu administracyjnego
Pomoc programu Administrator baz danych Asseco WAPRO > Funkcje modułu administracyjnego

Glossary Item Box

Funkcje modułu administracyjnego

Główne funkcje programu zgrupowane są w formie zakładek w następujące działy:

  • Bazy danych –zarządzanie bazami danych znajdującymi się na serwerze
  • Zaawansowane – konfiguracja serwera
  • Licencja – zarządzanie Licencją na użytkowanie programu
  • Połączenia – nadzór aktualnie podłączonych do serwera programów

Zobacz także

Tryb demonstracyjny
Zarządzanie bazami danych
Zakładka Zaawansowane
Zakładka Licencje
Zakładka połączenia


Tryb demonstracyjny
Pomoc programu Administrator baz danych Asseco WAPRO > Funkcje modułu administracyjnego > Tryb demonstracyjny

Glossary Item Box

Tryb demonstracyjny

Tryb demonstracyjny pozwala na bezpłatne zapoznanie się z programem lub jego nową wersją.

Aby utworzyć bazę w trybie demonstracyjnym, należy:

1. Uruchomić moduł administracyjny

2. Zalogować się do serwera, wciskając przycisk Połącz z serwerem.

3. W oknie przeglądania baz danych, kliknąć przycisk Utwórz nową bazę.

Powiększ Powiększ
Pomniejsz Pomniejsz

4. W oknie tworzenia bazy danych, wybrać nazwę bazy, licencję: Tryb DEMONSTRACYJNY i wybrać opcję Utwórz bazę.

Powiększ Powiększ
Pomniejsz Pomniejsz

5. Po utworzeniu bazy danych, przejść do okna Logowania do programu i klikając na przycisk Opcje >>, upewnić się, że bazą do której się logujemy, jest nowo utworzona przez nas baza i zalogować się, wciskając przycisk Zatwierdź.

Powiększ Powiększ
Pomniejsz Pomniejsz

Ekran logowania może zawierać dodatkowe opcje w zależności od uruchomionego programu.

6. Podczas logowania, można dokonać wyboru wariantu, w którym program ma się uruchomić, oraz dokonać odtworzenia w tej bazie przykładowych danych demonstracyjnych.

Powiększ Powiększ
Pomniejsz Pomniejsz

Warianty programu mogą się różnić w zależności od wybranej aplikacji.

Zobacz także

Zarządzanie bazami danych


Zarządzanie bazami danych
Pomoc programu Administrator baz danych Asseco WAPRO > Funkcje modułu administracyjnego > Zarządzanie bazami danych

Glossary Item Box

Zarządzanie bazami danych

Powiększ Powiększ
Pomniejsz Pomniejsz

Bazy danych przechowują dane programów. Każda baza danych jest niezależnym bytem, może być przenoszona między serwerami, oddzielnie archiwizowana oraz może zawierać struktury i dane różnych programów.

Programy Asseco WAPRO, mogą współpracować na wspólnej bazie danych. Dla przykładu program WF-Mag oraz WF-FaKir mogą współdzielić struktury w jednej bazie lub pracować na niezależnych bazach danych.

Po lewej stronie Okna Bazy danych znajduje się przeglądarka baz danych znajdujących się na serwerze. Do wyboru zakresu baz danych znajdującego się w przeglądarce służą trzy pola wyboru znajdujące się ponad nią :

  • Bazy zawierające struktury programu – wybranie tego pola pokazuje bazy danych zawierające struktury i dane naszego programu, czyli bazy, na których pracuje używany przez nas program.
  • Wszystkie bazy Asseco WAPRO – pokazuje bazy, które zawierają struktury jakichkolwiek programów Asseco WAPRO.
  • Wszystkie bazy danych – pokazuje wszystkie bazy danych – również te, na których programy Asseco WAPRO nie pracują.

Przeglądarka baz danych zawiera dwie kolumny :

  • Nazwa – w tej kolumnie pojawiają się nazwy baz danych
  • Programy – w tej kolumnie pojawiają się litery oznaczające programy Asseco WAPRO, których struktury zawiera dana baza danych :

A - WF-Analizy dla Windows

B – WF-bEST dla Windows

F – WF-FaKir dla Windows

K – WF-KaPeR dla Windows

M – WF-Mag dla Windows

G – WF-Gang dla Windows

Jeśli litera jest mała, to oznacza, że dla danego programu baza pracuje w trybie demonstracyjnym (tryb demonstracyjny umożliwia sprawdzenie możliwości programu bez konieczności posiadania licencji na jego użytkowanie).

Po prawej stronie okna znajduje się lista operacji jakie można wykonać na bazach danych :

Utwórz bazę danych – operacja ta powoduje utworzenie nowej bazy danych i zainstalowanie w niej struktur naszego programu. Wciśnięcie przycisku powoduje pojawienie się nowego okna:

Powiększ Powiększ
Pomniejsz Pomniejsz

W oknie tym można wpisać nazwę dla nowo tworzonej bazy danych oraz zaznaczyć, czy chcemy by została ona utworzona w :

  • licencji GŁÓWNEJ
  • trybie demonstracyjnym
  • licencjach Klienckich (patrz punkt Licencje klienckie)

W pewnych przypadkach część z tych funkcji będzie zablokowana :

  • jeśli nie posiadamy licencji na użytkowanie programu – będzie możliwe utworzenie bazy tylko w trybie demonstracyjnym
  • jeśli posiadamy licencję na program w wariancie Start – będzie można utworzyć tylko bazę o nazwie WAPRO, gdyż wariant Start pracuje tylko na bazie o nazwie WAPRO (jeśli wybierzemy tryb demonstracyjny, to bazie będzie można nadać dowolną nazwę).

Po wybraniu przycisku Utwórz bazę, program przejdzie do jej tworzenia i pokaże okienko z paskiem postępu :

Doinstaluj struktury programu – operacja ta powoduje doinstalowanie struktur programu do już istniejącej bazy danych. Może ona zostać wykonana tylko na bazie nie zawierającej struktur programu. Instalowanie struktur różnych programów Asseco WAPRO w jednej bazie danych ma tę zaletę, że programy współdzielą ze sobą pewne kartoteki, dzięki czemu pracownicy różnych działów firmy nie muszą wielokrotnie wpisywać tych samych danych.

Opcja doinstalowania struktur danego programu odbywa się za pomocą administratora baz danych tego konkretnego programu. Dla przykładu jeśli posiadamy bazę na której pracuje program WF-Mag a chcemy doinstalować do niego struktury programu WF-FaKir należy uruchomić administratora baz danych programu WF-FaKir.

Aktualizuj do wersji X.XX.X – operacja ta umożliwia aktualizację struktur programu do odpowiedniej wersji. Wykonuje się ją po zainstalowaniu nowej wersji programu. Jeśli struktury programu w danej bazie posiadają już odpowiednią wersję, program zapytuje czy na pewno chcemy wykonać tę operację.
Ustaw bazę domyślną dla programu – ustawia wybraną bazę jako bazę domyślną dla naszego programu na tym stanowisku. Przy wykonywaniu tej operacji wykonywane jest sprawdzenie poprawności numeru wersji struktur danych. W przypadku różnicy wersji programu i struktur bazy program informuje o tym i ewentualnie nakazuje aktualizację struktur bazy danych.
Pokaż programy i wersje struktur – przycisk pokazujący informację tekstową o programach wersjach i trybach demonstracyjnych programów pracujących na danej bazie, np:

Powiększ Powiększ
Pomniejsz Pomniejsz

Wyłącz tryb Demonstracyjny – operacja ta obejmuje licencją wybraną bazę danych pracującą w trybie demonstracyjnym. Umożliwia ona gładkie przejście z trybu demonstracyjnego do pracy na danych, które wpisał użytkownik przed zakupieniem programu.
Usuń bazę – powoduje bezpowrotne usunięcie danej bazy danych.
Odśwież informację o bazach – powoduje odczytanie informacji z każdej bazy danych znajdującej się na serwerze, dzięki czemu przeglądarka może prawidłowo pokazywać dane o programach pracujących na danej bazie. Opcja przydaje się jeśli baza programu była przeniesiona z innego serwera za pomocą narzędzi innych niż programy Asseco WAPRO.

Zobacz także

Tryb demonstracyjny
Zakładka Zaawansowane
Operacje wiersza poleceń


Zakładka Zaawansowane
Pomoc programu Administrator baz danych Asseco WAPRO > Funkcje modułu administracyjnego > Zakładka Zaawansowane

Glossary Item Box

Zakładka Zaawansowane

Powiększ Powiększ
Pomniejsz Pomniejsz

Administracja serwerem zawiera następujące funkcje:

  • Zmień hasło administratora serwera SQL (sa)
  • Podaj właściwości serwera (szczegółowe właściwości i parametry instalacji serwera)
  • Włącz logowanie serwisowe - funkcja serwisowa

Ponadto zakładka pokazuje informacje o serwerze SQL.

Powiększ Powiększ
Pomniejsz Pomniejsz

Administracja bazami danych zawiera następujące funkcje:

  • pobranie właściwości bazy (szczegółowe parametry bazy przydatne dla administratorów i serwisantów)
  • kompaktowanie bazy (zmniejszenie miejsca zajmowanego przez pliki bazy danych) (operacja DBCC Shrinkfile)

Kompaktowanie bazy danych zmniejsza rozmiar pliku bazy ale powoduje defragmentację indeksów co negatywnie wpływa na wydajność bazy. Dlatego zaleca się aby po wykonaniu tej operacji wykonać dodatkowo opcję Defragmentuj bazę. Jeśli nie ma konkretnych przesłanek do zmniejszania rozmiarów bazy nie należy jej wykonywać.

Funkcja powinna być uruchamiana na bazie kiedy nie pracują na niej użytkownicy.

  • konta użytkowników programu (przegląd kont użytkowników programu, generacja nowych haseł)
  • zmiana nazwy bazy danych (operacja ryzykowna - należy wcześniej dokonać archiwizacji bazy)

Wykonywać tylko kiedy użytkownicy nie pracują na bazie)

  • archiwizuj bazę (szybki sposób na archiwizację bazy danych)

Operacja uruchamia moduł Archiwizatora baz danych Asseco WAPRO.

  • defragmentuj bazę - administrator dokona defragmentacji indeksów w bazie danych, operacja może potrwać od kilku do kilkudziesięciu minut w zależności od wielkości bazy danych

W bazadach danych, w których bardzo często dochodzi do modyfikacji danych oraz dodawania i kasowania, w celu zwiększenia wydajności pracy aplikacji zaleca się wykonywanie raz na jakiś czas operacji defragmentacji bazy.

Nie ma jednoznacznej odpowiedzi jaka powinna być częstotliwość tej operacji, jest ona uzależniona od charakteru pracy firmy oraz częstotliwości zmian. Można przyjąć przy bardzo dużej ilości zmian harmonogram raz na tydzień.

Powiększ Powiększ
Pomniejsz Pomniejsz

Pobieranie nowych wersji programu – funkcja ta umożliwia wejście do okna zarządzającego częstością odpytywania serwera aktualizacji o aktualną wersję lub edycję programu. Odpytywanie serwera odbywa się w czasie gdy na ekranie widnieje okienko logowania do programu. Jeśli na serwerze istnieje nowsza wersja, to moduł poinformuje o tym użytkownika i umożliwi pobranie nowszej wersji. Oprócz zmiany częstości można też odpytać serwer w każdej chwili wciskając przycisk Pobierz informacje o dostępnych wersjach teraz.

Konfiguracja ta dotyczy tylko tego stanowiska na którym został uruchomiony moduł administracyjny.

Jeśli system wykryje nową wersję i użytkownik wyrazi chęć jej pobrania system rozpocznie proces pobierania. Pobieranie będzie wykonywało się niezależnie od działania aplikacji. Po zakończeniu pobierania, należy zamknąć wszystkie programy i uruchomić instalację programu. Jeśli program pobierający zostanie zamknięty, to można wznowić pobieranie odpytując serwer o nowe wersje i ponownie uruchamiając pobieranie.

Powiększ Powiększ
Pomniejsz Pomniejsz

Zobacz także

Zakładka Licencje
Operacje wiersza poleceń


Zakładka Licencje
Pomoc programu Administrator baz danych Asseco WAPRO > Funkcje modułu administracyjnego > Zakładka Licencje

Glossary Item Box

Zakładka Licencje

Konfiguracja licencji na użytkowanie programu umożliwia użytkowanie programu w konfiguracji zgodnej z tą jaka została zakupiona. Okno licencji będzie zawierać różne informacje w zależności od stanu w jakim znajduje się licencja. Jeśli przy pierwszym logowaniu po pojawieniu się zapytania o rodzaj tworzonej licencji:

  • został wybrany przycisk Demonstracja, to licencja znajdzie się w trybie demonstracyjnym. Do czasu utworzenia licencji będzie można użytkować program i tworzyć bazy danych w trybie demonstracyjnym.

Wejście na zakładkę licencja umożliwi utworzenie informacji licencyjnej i rozpoczęcie komercyjnego użytkowania programu.

  • Jeśli przy pierwszym logowaniu wybrany został przycisk Utworzenie licencji to pojawi się okno wyboru z następującymi opcjami do wyboru :

Należy wybrać przycisk odpowiadający naszemu stanowi posiadania.

Z dniem pierwszego czerwca 2004 roku Asseco WAPRO wprowadziło nowe Certyfikaty autentyczności zawierające numer licencji oraz zdrapkę zawierającą kod tajny. Każdy pakiet, który opuścił naszą firmę po tym dniu zawiera taki certyfikat.

Zobacz także

Tworzenie licencji
Licencje klienckie


Tworzenie licencji
Pomoc programu Administrator baz danych Asseco WAPRO > Funkcje modułu administracyjnego > Licencje > Tworzenie licencji

Glossary Item Box

Tworzenie licencji

Po dokonaniu wyboru opcji pojawia się okno wprowadzania danych licencji :

  • zakładka Dane podstawowe:

Powiększ Powiększ
Pomniejsz Pomniejsz

W przypadku wybrania drugiej opcji (wcześniejsze zakupienie programu) – nie będzie dostępne okienko Certyfikaty, natomiast w przypadku opcji trzeciej – Nie będzie można wpisać numeru licencji i Certyfikatów.

Opis pól :

Wersja – pokazuje wersję programu, którą będzie można użytkować bez konieczności wykupienia aktualizacji – w tym przypadku jest to 7.7x.x, co oznacza, że bez wykupienia aktualizacji będzie można użytkować program do czasu gdy nie pojawi się wersja 7.80.0 lub nowsza.

Wariant – tutaj należy wybrać wariant programu jaki chcemy użytkować. Od wariantu programu zależy zakres funkcjonalności programu jaka będzie dostępna dla użytkownika.

Numer licencji – tutaj należy wpisać numer licencji z Certyfikatu Autentyczności – o ile taki posiadamy.

Certyfikaty – w przypadku posiadania Certyfikatu Autentyczności (lub wielu certyfikatów) ze zdrapkami należy go dodać używając przycisk Dodaj.

Liczba stanowisk - oznacza liczbę stanowisk na jakiej użytkownicy zamierzają pracować. W przypadku programu WF-bEST zamiast liczby stanowisk zasobem limitowanym jest ilość obsługiwanych środków trwałych. W programie WF-Gang – ilość pracowników.

Jeśli użytkownik posiada Certyfikaty Autentyczności to liczba stanowisk jest przez nie określona, w przeciwnym razie należy podać liczbę na jakiej zamierzamy pracować – zostaną one zweryfikowane podczas aktywacji licencji.

zakładka Dane firmy :

Powiększ Powiększ
Pomniejsz Pomniejsz

W tej zakładce należy podać dane swojej firmy – muszą one być tożsame z tymi, które zostały podane podczas zakupu programu – dzięki temu proces aktywacji licencji przebiegnie sprawniej.

Zakładka Dane firmy c.d.

Powiększ Powiększ
Pomniejsz Pomniejsz

Wybranie znacznika ‘... zezwalam Asseco WAPRO na przetwarzanie moich danych osobowych w celach marketingowych i promocyjnych’ pozwoli na wysyłanie do Państwa materiałów promocyjnych.
Wybranie znacznika ‘... wyrażam zgodę na otrzymywanie informacji z Asseco WAPRO na nasz adres elektroniczny ...’ pozwoli na wysyłanie do Państwa materiałów marketingowych za pośrednictwem poczty elektronicznej na wybrany przez Państwa adres e-mail.

zakładka Dane sprzedawcy:

Powiększ Powiększ
Pomniejsz Pomniejsz

W tej zakładce należy podać dane firmy od której zakupiliśmy program. Dzięki podaniu tych informacji klient będzie sprawniej obsługiwany w czasie użytkowania programu.

zakładka Aktywacja:

Powiększ Powiększ
Pomniejsz Pomniejsz

Uwaga!

Podczas przejścia z zakładki Dane sprzedawcy do zakładki Aktywacja weryfikowane jest połączenie z internetem. Jeśli użytkownik posiada połączenie następuje próba aktywacji programu. Jeśli nie uda się zaktywować programu, próba będzie ponawiana podczas każdorazowego logowania się do aplikacji, której ta licencja dotyczy np. WF-Mag. Jeśli użytkownik nie posiada dostępu do internetu lub aktywacja online nie jest możliwa można skorzystać

Na tej zakładce należy wpisać informacje pozwalające na sprawną komunikację.

Część Wybierz sposób otrzymania kodu aktywacyjnego określa drogę, którą Asseco WAPRO prześle do Państwa kod aktywacyjny pozwalający na uzyskanie PEŁNEJ aktywności programu.

Na zakończenie należy wybrać sposób generacji karty rejestracyjnej (Zamówienia). Do wyboru mamy :

  • Zapisz do pliku
  • Drukuj
  • Wyślij pocztą e-mail

Po wybraniu odpowiedniego sposobu generacji zamówienia należy wcisnąć przycisk Zapisz licencję.

Program wygeneruje zamówienie i ustawi licencję w stan wstępny. W stanie wstępnym będzie można użytkować program w czasie 30 dni. W tym czasie należy wysłać wygenerowane zamówienie do Asseco WAPRO w celu uzyskania kodu aktywacyjnego.

Po przejściu licencji w stan aktywności wstępnej zakładka Licencja zmieni swój wygląd :

Powiększ Powiększ
Pomniejsz Pomniejsz

Po lewej stronie pojawi się opis aktualnej konfiguracji licencji, po prawej pojawią się nowe funkcje :

Zmiana parametrów licencji – za pomocą tej funkcji można dokonać zmiany konfiguracji programu.

Następnie możliwe jest ponowne wygenerowanie zamówienia. Zmian parametrów licencji można dokonywać do czasu wygaśnięcia aktywności wstępnej.
Zamówienie najnowszej wersji – funkcja ta umożliwia złożenie zamówienia na najnowszą wersję programu. Dokonuje się tego w ten sam sposób jak utworzenie licencji.
Wprowadzenie kodu aktywacyjnego – umożliwia uzyskanie pełnej aktywności licencji programu poprzez wpisanie kodu aktywacyjnego uzyskanego od Asseco WAPRO. Po wybraniu tej funkcji pojawia się okienko :

Powiększ Powiększ
Pomniejsz Pomniejsz

W tym okienku należy wpisać kod aktywacyjny.

Powtórna generacja zamówienia – umożliwia ponowne wygenerowanie zamówienia na kod aktywacyjny – w przypadku jego zgubienia.
Internetowy serwis aktywacyjny – uruchamia przeglądarkę internetową i otwiera stronę na której można uzyskać kod aktywacyjny drogą internetową. Warunkiem uzyskania kodu aktywacyjnego jest zarejestrowanie płatności za zakup programu.

Zobacz także

Licencje klienckie


Licencje klienckie
Pomoc programu Administrator baz danych Asseco WAPRO > Funkcje modułu administracyjnego > Licencje > Licencje klienckie

Glossary Item Box

Licencje klienckie

W przypadku, gdy istnieje konieczność pracy na warunkach różnych licencji – konieczne staje się wprowadzenie informacji o dodatkowych licencjach. Wejście w moduł zarządzania licencjami klienckimi znajduje się na zakładce Licencja pod przyciskiem Licencje Klienckie. Po przyciśnięciu tego przycisku ukazuje się następujące okno:

Powiększ Powiększ
Pomniejsz Pomniejsz

Okno to umożliwia tworzenie, modyfikowanie, aktywowanie i usuwanie wielu licencji klienckich. Kolejne zdefiniowane licencje klienckie pojawiają się w lewym panelu okna. Klikając na listę, można zobaczyć poniżej szczegóły danej licencji.

Tworzenie licencji odbywa się prawie tak samo jak tworzenie informacji licencyjnej Licencji Głównej – z tą różnicą, że na zakładce „Dane firmy” pojawia się pole „Nazwa krótka”. Ta nazwa musi być unikalna w obrębie wszystkich licencji klienckich danego programu – będzie ona identyfikowała tę licencję podczas operacji wiązania baz danych z tą licencją.

Utworzoną licencję kliencką można powiązać z wybranymi bazami danych.

Można tego dokonać na dwa sposoby:

a) Podczas tworzenia nowej bazy danych można dokonać wyboru licencji z którą będzie powiązana nowo tworzona baza. Jest to jedyny sposób łączenia bazy w przypadku, gdy licencja jest w trybie aktywności wstępnej.

Powiększ Powiększ
Pomniejsz Pomniejsz

b) Poprzez wiązanie licencji.

Ta funkcjonalność znajduje się na ekranie „Licencje Klienckie” – pod przyciskiem „Wiązanie licencji z bazami”. Po wciśnięciu przycisku pojawia się okno :

Powiększ Powiększ
Pomniejsz Pomniejsz

Po lewej stronie znajduje się lista baz zawierających struktury naszego programu, oraz nazwę licencji z którą jest ona aktualnie powiązana. DEMO – oznacza tryb demonstracyjny, GŁÓWNA – licencję główną, natomiast inne nazwy oznaczają licencję kliencką.

Zmiany przyporządkowania danej bazy danych do licencji dokonuje się za pomocą przycisku „Zmień licencję”. Wówczas pojawia się okienko z wyborem licencji, do których można przyporządkować daną bazę danych. Jeśli system uzna, że nie ma żadnej licencji, do której można przyporządkować daną bazę danych – to wówczas poinformuje o tym stosownym komunikatem.

Licencję można zmienić tylko na taką, która jest w aktywności Pełnej oraz jej wersja (pierwsze dwie cyfry) jest większa lub równa dotychczasowej licencji.

Zobacz także

Tworzenie licencji


Zakładka połączenia
Wyślij wiadomość Pytania i odpowiedzi
Pomoc programu Administrator baz danych Asseco WAPRO > Funkcje modułu administracyjnego > Zakładka połączenia

Glossary Item Box

Zakładka Połączenia

Zakładka Połączenia pozwala na śledzenie aktywności programów podłączonych do serwera SQL. Umożliwia ona również odłączenie danego programu w przypadku zawieszenia się danego komputera. Służy do tego przycisk Usuń

Operacja usunięcia danego połączenia może potrwać nawet do kilku minut

Powiększ Powiększ
Pomniejsz Pomniejsz

Pojawiające się po lewej stronie ekranu piktogramy z żółtymi twarzami pokazują czy dany program aktywnie działa na serwerze. W przypadku, gdy program nie wykonał żadnej operacji w ciągu dwóch minut, twarz zmieni stan z uśmiechniętej na smutną.

Przycisk Odśwież pozwala na ponowne odczytanie stanu połączeń.


Operacje wiersza poleceń
Wyślij wiadomość Pytania i odpowiedzi
Pomoc programu Administrator baz danych Asseco WAPRO > Operacje wiersza poleceń

Glossary Item Box

Operacje wiersza poleceń

Administrator baz danych Asseco WAPRO może wykonywać operacje w trybie nienadzorowanym za pomocą parametrów wiersza poleceń.

Do takich operacji zaliczają się:

- aktualizacja bazy danych

- kompaktowanie bazy danych (polecenie SHRINK)

- defragmentacja bazy danych (defragmentacja indeksów)

Operacje te mogą być wykonywanie niezależnie lub łącznie. Aby wykonać te operacje należy uruchomić plik administrator.exe znajdujący się w katalogu programu z odpowiednimi parametrami.

Poniżej zaprezentowano listę parametrów ich opis oraz przykładowe wywołania.

Parametry

AUTO_UPDATE - parametr odpowiadający aktualizacji bazy danych, jeśli baza jest w odpowiedniej wersji dla danego administratora, zostanie wymuszona ponowna aktualizacja. Jest to parametr, który musi być podany zawsze jeśli używane są inne parametry. Jeśli użytkownik poda dodatkowe parametry system nie dokona ponownej aktualizacji a jedynie wykona dodatkowe operacje przypisane do dodatkowych parametrów.

COMPRESS - parametr odpowiada za wykonanie operacji kompaktowania bazy danych.

DEFRAGM - parametr odpowiada za wykonanie operacji defragmentacji bazy danych (defragmentacja indeksów). Jeśli użytkownik poda ten parametr łącznie z opcją COMPRESS w pierwszej kolejności zostanie wykonane kompaktowanie bazy a dopiero defragmentacja.

SERVER - parametr określa nazwę serwera do jakiego ma nastąpić połączenie. Jeśli parametr nie zostanie podany, administrator odczyta go z pliki konfiguracyjnego INI.

DBNAME=nazwa_bazy - parametr, który wskazuje na jakiej bazie ma być wykonana dana operacja. Nazwa bazy danych powinna być wprowadzona po znaku = .

WIN_AUTH - parametr określający, że ma zostać użyte uwierzytelnianie Windows do procesu logowania. Jeśli ten parametr zostanie pominięty i nie zostaną podane dane uwierzytelniające konta SQL system wykorzysta wbudowane konto aplikacji.

LOGIN - parametr odpowiada za podanie nazwy konta SQL. Należy go podać tylko w przypadku nie wykorzystywania WIN_AUTH oraz chęci nawiązania na innym koncie niż wbudowane dla aplikacji.

PASSWORD - parametr odpowiada za hasło konta SQL. Należy go podać tylko w przypadku nie wykorzystywania WIN_AUTH oraz chęci nawiązania na innym koncie niż wbudowane dla aplikacji.

Wielkość liter nie ma znaczenia w nazwach parametrów.

Przykładowe wywołania

administrator.exe auto_update dbname=wapro_demo win_auth - powoduje uruchomienie procesu aktualizacji bazy danych do najwyższej wersji odpowiadającej danemu administratorowi

administrator.exe auto_update compress dbname=wapro_demo win_auth - powoduje uruchomienie tylko procesu kompaktowania bazy danych

administrator.exe auto_update defragm dbname=wapro_demo win_auth - powoduje uruchomienie tylko procesu defragmentacji bazy danych

administrator.exe auto_update defragm compress dbname=wapro_demo win_auth - powoduje uruchomienie w pierwszej kolejności kompaktowania bazy a następnie defragmentacji

administrator.exe auto_update defragm compress dbname=wapro_demo - powoduje uruchomienie jak powyżej ale z wykorzystaniem wbudowanego konta aplikacji, nazwa serwera odczytywana jest z pliku INI

administrator.exe auto_update defragm compress dbname=wapro_demo server=. login=sa password=sa - powoduje uruchomienie jak powyżej ale dla wskazanego konkretnego serwera z podaniem nazwy loginu SQL oraz odpowiadającym hasłem dla danego loginu.


Wzorzec
Wyślij wiadomość Pytania i odpowiedzi

Glossary Item Box

Tytuł

©2013. Wszelkie prawa zastrzeżone.